Skip to content
MongoDB · Data and observabilityJul 9, 2026, 10:23 UTC

Atlas Data Federation and Online Archive cloud-provider IAM authentication error

MinorConfig changeUpdated 19h ago
Jul 9, 10:23 UTCJul 9, 11:06 UTC
Duration
43m
Impact
Minor
Root cause
Config change
MongoDB, 90 days
19 incidents
Affected
MongoDB Atlas Data Federation and Online Archive
Status page

Final update

This incident has been resolved.

Timeline

  1. Resolved · Jul 9, 11:06 UTC
    This incident has been resolved.
  2. Monitoring · Jul 9, 11:01 UTC
    A fix has been implemented and we are monitoring the results.
  3. Identified · Jul 9, 10:57 UTC
    We have identified that the issue is caused by a recent configuration change to IAM authentication and are working on a fix.
  4. Investigating · Jul 9, 10:23 UTC
    Users of Atlas Data Federation and Online Archive using cloud-provider IAM authentication may see pipelines fail with an error when querying backing Atlas clusters. Other authentication methods are unaffected. As a temporary workaround, users can use SCRAM authentication.

More from MongoDB

Full history

Also caused by configuration change

All
StartedIncidentDuration
Sep 2218:20 UTCPhone Number APIs and Console Were Returning Incorrect 404 ResponsesTwilio0m
Sep 1622:30 UTCHyperdrive Elevated Origin Connection Failure RatesCloudflare0m
Sep 1211:04 UTCSome customers experiencing blurry image previews and download issuesSlack8h 56m
Sep 1107:18 UTCINC20000213Snowflake6h 1m
Sep 407:34 UTCINC20000199Snowflake2h 36m
Sep 109:58 UTCINC20000190Snowflake3h 52m

From vendors' own status pages and disclosures. Times as reported. Logos via logo.dev; trademarks belong to their owners.

Weekly: the week's major outages, postmortems and breaches, Saturday mornings.