Skip to content
Snowflake · Data and observabilityNov 20, 2025, 20:19 UTC

Azure - Australia East (New South Wales): INC0147071

CriticalConfig changeUpdated 20h ago
Nov 20, 20:19 UTCNov 20, 23:01 UTC
Duration
2h 42m
Impact
Critical
Root cause
Config change
Snowflake, 90 days
22 incidents
Affected
Not listed by the vendor.
Status page

Final update

Current status: We've implemented the fix for this issue and monitored the environment to confirm that service was restored. If you experience additional issues or have questions, please open a support case via Snowflake Community. Customer experience: Customers hosted in the specified regions may have been unable to access or use multiple core Snowflake services and features. Affected users may have been unable to sign in, execute queries, or manage data. Incident start time: 19:50 UTC November 20, 2025 Incident end time: 21:15 UTC November 20, 2025 Preliminary root cause: Our investigation identified that a recent configuration change to our firewall rules resulted in a communication issue between our Cloud Services and Storage layer infrastructure. As a result, customer requests were unable to be processed successfully. A root cause analysis (RCA) document will be published within five business days.

Timeline

  1. Resolved · Nov 20, 23:01 UTC
    Current status: We've implemented the fix for this issue and monitored the environment to confirm that service was restored. If you experience additional issues or have questions, please open a support case via Snowflake Community. Customer experience: Customers hosted in the specified regions may have been unable to access or use multiple core Snowflake services and features. Affected users may have been unable to sign in, execute queries, or manage data. Incident start time: 19:50 UTC November 20, 2025 Incident end time: 21:15 UTC November 20, 2025 Preliminary root cause: Our investigation identified that a recent configuration change to our firewall rules resulted in a communication issue between our Cloud Services and Storage layer infrastructure. As a result, customer requests were unable to be processed successfully. A root cause analysis (RCA) document will be published within five business days.

More from Snowflake

Full history
StartedIncidentDuration
Sep 1404:48 UTCINC200002171h 21m
Sep 1107:18 UTCINC200002136h 1m
Sep 921:53 UTCINC200002111h 58m
Sep 407:34 UTCINC200001992h 36m
Sep 109:58 UTCINC200001903h 52m
Aug 3117:20 UTCINC200001882h 24m

Also caused by configuration change

All
StartedIncidentDuration
Sep 2218:20 UTCPhone Number APIs and Console Were Returning Incorrect 404 ResponsesTwilio0m
Sep 1622:30 UTCHyperdrive Elevated Origin Connection Failure RatesCloudflare0m
Sep 1211:04 UTCSome customers experiencing blurry image previews and download issuesSlack8h 56m
Sep 108:01 UTCSentry requests timing out / 504'sSentry3h 20m
Aug 2620:00 UTCFlag delivery errors in Streaming APILaunchDarkly0m
Aug 2407:19 UTCDegraded Git Operations over SSHGitHub0m

From vendors' own status pages and disclosures. Times as reported. Logos via logo.dev; trademarks belong to their owners.

Weekly: the week's major outages, postmortems and breaches, Saturday mornings.