Skip to content
Supabase · Data and observabilityMay 9, 2026, 15:00 UTC

Error spikes in one of the eu-central-1 Supavisor clusters

MinorNot disclosedUpdated 18h ago
May 9, 15:00 UTCMay 9, 15:00 UTC
Duration
0m
Impact
Minor
Root cause
Not disclosed
Supabase, 90 days
56 incidents
Affected
Not listed by the vendor.
Status page

Final update

Between 15:25 and 15:33 and between 15:38 and 15:41 we observed error spikes in one of the eu-central-1 Supavisor clusters. Users reported failures in connecting to postgres via Supavisor Errors reported: ClientHandler: (ECHECKOUTTIMEOUT) unable to check out connection from the pool after 15000ms in Transaction mode

Timeline

  1. Resolved · May 9, 15:00 UTC
    Between 15:25 and 15:33 and between 15:38 and 15:41 we observed error spikes in one of the eu-central-1 Supavisor clusters. Users reported failures in connecting to postgres via Supavisor Errors reported: ClientHandler: (ECHECKOUTTIMEOUT) unable to check out connection from the pool after 15000ms in Transaction mode

More from Supabase

Full history

From vendors' own status pages and disclosures. Times as reported. Logos via logo.dev; trademarks belong to their owners.

Weekly: the week's major outages, postmortems and breaches, Saturday mornings.