S3 endpoints for keys with special characters broken
Jul 16, 17:55 UTCJul 16, 18:49 UTC
Duration
54m
Impact
Minor
Root cause
Not disclosed
Supabase, 90 days
56 incidents
Affected
Storage
Final update
This incident has been resolved. A recent API Gateway deployment altered how certain special characters in S3 object key paths were encoded before reaching storage, causing signature verification failures (403) for affected requests. The change has been reverted and issue is now fixed.
Timeline
- Resolved · Jul 16, 18:49 UTC
This incident has been resolved. A recent API Gateway deployment altered how certain special characters in S3 object key paths were encoded before reaching storage, causing signature verification failures (403) for affected requests. The change has been reverted and issue is now fixed.
- Identified · Jul 16, 18:32 UTC
We have implemented a PR rollback to mitigate this issue. We will actively monitor its progress
- Identified · Jul 16, 18:23 UTC
A likely mitigation has been identified and we are discussing the proper implementation method.
- Identified · Jul 16, 17:55 UTC
We have identified an issue where S3 endpoints for keys with special characters will be broken. We are actively investigating the correct mitigation for this issue.
More from Supabase
Full history| Started | Incident | Impact | Duration |
|---|---|---|---|
| Sep 2321:58 UTC | Supabase CLI CI workflow failures | minor | 1h 42m |
| Sep 2309:31 UTC | Storage search failing for restored projects | minor | Ongoing |
| Sep 2309:21 UTC | Increased error rate in project creation and project restore | major | 1h 28m |
| Sep 2210:49 UTC | Supavisor connection disruptions in EU West 1 (Ireland) | minor | 1h 31m |
| Sep 2208:33 UTC | Project creations are degraded in multiple regions | minor | 31m |
| Sep 1920:12 UTC | Project Lifecycle Activity Degradation | major | 2h |
From vendors' own status pages and disclosures. Times as reported. Logos via logo.dev; trademarks belong to their owners.