Skip to content
Snowflake · Data and observabilityDec 16, 2025, 03:48 UTC

INC0148543

CriticalDeploymentUpdated 17h ago
Dec 16, 03:48 UTCDec 16, 17:25 UTC
Duration
13h 37m
Impact
Critical
Root cause
Deployment
Snowflake, 90 days
22 incidents
Affected
Not listed by the vendor.
Status page

Final update

Current status: We've implemented the fix for this issue and monitored the environment to confirm that the service was restored. Some customers may experience delays in ingestion as the backlog of requests is cleared. If you experience additional issues or have questions, please open a support case via Snowflake Community. Customer experience: Customers hosted in the specified regions may have been unable to execute queries and may have experienced query performance degradation. Additionally, data clustering may have appeared to be in an unhealthy state. Users may have experienced delays or failures when using Snowpipe or Snowpipe Streaming to ingest files, and users may have seen a "SQL execution internal error" message or similar error messages. Workaround: There were no available workarounds for this issue except for customers with replication failing over to non-impacted regions. Incident start time: 02:55 UTC December 16, 2025 Incident end time: 15:59 UTC December 16, 2025 Preliminary root cause: Our initial investigation has identified that our most recent release introduced a backwards-incompatible database schema update. As a result, previous release packages incorrectly r

Timeline

  1. Resolved · Dec 16, 17:25 UTC
    Current status: We've implemented the fix for this issue and monitored the environment to confirm that the service was restored. Some customers may experience delays in ingestion as the backlog of requests is cleared. If you experience additional issues or have questions, please open a support case via Snowflake Community. Customer experience: Customers hosted in the specified regions may have been unable to execute queries and may have experienced query performance degradation. Additionally, data clustering may have appeared to be in an unhealthy state. Users may have experienced delays or failures when using Snowpipe or Snowpipe Streaming to ingest files, and users may have seen a "SQL execution internal error" message or similar error messages. Workaround: There were no available workarounds for this issue except for customers with replication failing over to non-impacted regions. Incident start time: 02:55 UTC December 16, 2025 Incident end time: 15:59 UTC December 16, 2025 Preliminary root cause: Our initial investigation has identified that our most recent release introduced a backwards-incompatible database schema update. As a result, previous release packages incorrectly referenced the updated fields, resulting in version mismatch errors and causing operations to fail or take an extended amount of time to complete. A root cause analysis (RCA) document will be published within five business days.

More from Snowflake

Full history
StartedIncidentDuration
Sep 1404:48 UTCINC200002171h 21m
Sep 1107:18 UTCINC200002136h 1m
Sep 921:53 UTCINC200002111h 58m
Sep 407:34 UTCINC200001992h 36m
Sep 109:58 UTCINC200001903h 52m
Aug 3117:20 UTCINC200001882h 24m

Also caused by deployment or rollout

All
StartedIncidentDuration
Sep 1106:22 UTCIssues with Workers VPC hostname route resolution on 2026-09-11Cloudflare0m
Aug 2014:43 UTCIntermittent failures creating agent tasksGitHub9h 54m
Aug 2000:31 UTC[Medium] Issue with Microsoft Office Integration and Box EditBox1h 13m
Aug 622:22 UTCTrouble Using Search Bar For Some AdminsSlack2h 44m
Jul 2110:23 UTCJob runs failing at the git clone stepdbt Labs2h 29m
Jul 1907:33 UTCSome EMEA customers experiencing Git clone failures (403 errors) on thier accountsdbt Labs6h 22m

From vendors' own status pages and disclosures. Times as reported. Logos via logo.dev; trademarks belong to their owners.

Weekly: the week's major outages, postmortems and breaches, Saturday mornings.