INC0148543
Final update
Current status: We've implemented the fix for this issue and monitored the environment to confirm that the service was restored. Some customers may experience delays in ingestion as the backlog of requests is cleared. If you experience additional issues or have questions, please open a support case via Snowflake Community. Customer experience: Customers hosted in the specified regions may have been unable to execute queries and may have experienced query performance degradation. Additionally, data clustering may have appeared to be in an unhealthy state. Users may have experienced delays or failures when using Snowpipe or Snowpipe Streaming to ingest files, and users may have seen a "SQL execution internal error" message or similar error messages. Workaround: There were no available workarounds for this issue except for customers with replication failing over to non-impacted regions. Incident start time: 02:55 UTC December 16, 2025 Incident end time: 15:59 UTC December 16, 2025 Preliminary root cause: Our initial investigation has identified that our most recent release introduced a backwards-incompatible database schema update. As a result, previous release packages incorrectly r
Timeline
- Resolved · Dec 16, 17:25 UTC
Current status: We've implemented the fix for this issue and monitored the environment to confirm that the service was restored. Some customers may experience delays in ingestion as the backlog of requests is cleared. If you experience additional issues or have questions, please open a support case via Snowflake Community. Customer experience: Customers hosted in the specified regions may have been unable to execute queries and may have experienced query performance degradation. Additionally, data clustering may have appeared to be in an unhealthy state. Users may have experienced delays or failures when using Snowpipe or Snowpipe Streaming to ingest files, and users may have seen a "SQL execution internal error" message or similar error messages. Workaround: There were no available workarounds for this issue except for customers with replication failing over to non-impacted regions. Incident start time: 02:55 UTC December 16, 2025 Incident end time: 15:59 UTC December 16, 2025 Preliminary root cause: Our initial investigation has identified that our most recent release introduced a backwards-incompatible database schema update. As a result, previous release packages incorrectly referenced the updated fields, resulting in version mismatch errors and causing operations to fail or take an extended amount of time to complete. A root cause analysis (RCA) document will be published within five business days.
More from Snowflake
Full history| Started | Incident | Impact | Duration |
|---|---|---|---|
| Sep 1404:48 UTC | INC20000217 | major | 1h 21m |
| Sep 1107:18 UTC | INC20000213 | critical | 6h 1m |
| Sep 921:53 UTC | INC20000211 | critical | 1h 58m |
| Sep 407:34 UTC | INC20000199 | critical | 2h 36m |
| Sep 109:58 UTC | INC20000190 | major | 3h 52m |
| Aug 3117:20 UTC | INC20000188 | critical | 2h 24m |
Also caused by deployment or rollout
All| Started | Vendor | Incident | Impact | Duration |
|---|---|---|---|---|
| Sep 1106:22 UTC | Issues with Workers VPC hostname route resolution on 2026-09-11 | none | 0m | |
| Aug 2014:43 UTC | Intermittent failures creating agent tasks | critical | 9h 54m | |
| Aug 2000:31 UTC | [Medium] Issue with Microsoft Office Integration and Box Edit | major | 1h 13m | |
| Aug 622:22 UTC | Trouble Using Search Bar For Some Admins | minor | 2h 44m | |
| Jul 2110:23 UTC | Job runs failing at the git clone step | critical | 2h 29m | |
| Jul 1907:33 UTC | Some EMEA customers experiencing Git clone failures (403 errors) on thier accounts | major | 6h 22m |
From vendors' own status pages and disclosures. Times as reported. Logos via logo.dev; trademarks belong to their owners.